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INTRODUCTION 
 

MailSecurium™ is a part of the SWISS SECURIUM® Platform, which is a special platform for secure 

communication, storage and exchange of information and documents. Reliable data centre ensures 

maximum security.   

Since foundation we have been successfully protecting communication. The highest corporate 

communication security is our main goal. 

100% are made and protected in Switzerland. 

 

FUNCTIONALITY 
 

MailSecurium™ is an email service of the SWISS SECURIUM® Platform. It can be used through an 

email application as well as through a browser.  

Public email services can’t provide full privacy, they also may contain advertisement while 

MailSecurium™ may be stored on your own servers or in our protected data centre and doesn’t 

contain ad. 

Key functions: 

 Mailbox  

 Calendar  

 Address book  

 Synchronization with Thunderbird 

 

1 MailSecurium™ WEB 
 

To login to MailSecurium™: 

1. Go to start page:  

https://ProductID.securium.ch/ 

2. Click on MailSecurium™ logo. 

3. Enter your Username & Password. 

4. Click Login. 

https://productid.securium.ch/
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1.1 Mailbox 
 

The MailSecurium™ web mailbox has the appearance and functionality similar to other email 

services: 

 

To view general email settings, click on the settings icon next to your Username in the upper left 

corner: 
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 Attention! If you want the email addresses of outgoing messages to be collected in some 

Address Book, tick the appropriate checkbox and select the Address Book to save. 

Any folder from your mailbox has a number of options. To see them, click the menu icon near the 

folder name . 

 

You can share mailbox folders with all users, groups of users or separate users of the SWISS 

SECURIUM® Platform:  
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1.2 Address Book 
 

Web interface of MailSecurium™ allows to manage your Address Books easily and conveniently. 

 

Any Address Book has a number of options. To see them, click the menu icon near its name . 

 

To enable Address Book synchronization across your devices (and for shared users), tick 

<Synchronize> in the Properties section of the menu: 
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You can share your Address Books with all users, groups of users or separate users of the SWISS 

SECURIUM® Platform: click the menu icon next to the Address Book name  and choose 

<Sharing…> section in the drop-down menu. Then choose users to share the Address Book with: 

 

And specify access rights for the chosen users: 

 

 
 

Similarly, you can subscribe to available Address 

Books of users in your company’s SWISS 

SECURIUM® instance: click the + icon next to the 

<Subscriptions> section of the Address Book menu. 
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Then enter the name of the user whose Address Book you want to subscribe to: 

 

<Shared Addresses> section contains the list of all the platform instance users. To see them all, just 

type “.” in search. Otherwise you can search by username, email, category or organization labels. 
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1.3 Calendar 
 

One of the most convenient features of webmail MailSecurium™ is calendars. You can easily engage 

in personal time management, creating events and tasks in a Personal Calendar, as well as watch and 

participate in joint work by subscribing to Shared Calendars of a company, teams or individual 

employees. 

 
 

The calendar view menu allows you to customize its appearance for your convenience: 

 

 – expand calendar area; 

 – flip date ranges; 

 – choose a date; 

 – return to current date; 

 – switch calendar appearance. 

To create new calendar, click + icon next to the <Calendars> section of the side menu: 
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Then enter a name for the new calendar:  

 

You can manage calendar settings through the calendar menu: click its icon  next to the calendar 

name. 

 

<Properties> section in the drop-down menu allows you to adjust completeness of displaying 

calendar items and notification sending: 
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If you want to share a calendar, choose <Sharing…> section in the drop-down calendar menu: 

 

Then enter username of the user / user group you want to share your calendar with. 

 

You can also share the calendar with all users of your SWISS SECURIUM® instance: 

 

Next step is to select settings and permissions for the shared calendar: 
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You can subscribe to any shared calendar. To do this, click the + icon next to the <Subscriptions> 

section of the menu: 

 

Then enter username or name of the user group whose calendar you want to subscribe to, and select 

necessary calendar(s): 
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To subscribe to a web calendar, click on the + icon next to the corresponding menu section: 

 

 Attention! Only CalDAV protocol links are supported: 
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2 WORK WITH MailSecurium™ VIA THUNDERBIRD 
 

You can use any email client to work with MailSecurium™, however Thunderbird is a popular and 

stable cross-platform client with a large number of add-ons and connectors, so we recommend that 

you use it (but don’t insist).  

Below there’ll be described how to synchronize webmail with Thunderbird. Other mail clients 

synchronize in a similar manner, but may have their own features. 

 

2.1 Adding of mailbox 
 

Open File menu (to show the menu bar, press ‘Alt’ key) and select item <New> → <Existing mail 

account>: 

 

Usually email and password are enough to configure email automatically. But in some cases in 

Thunderbird it may be required to specify SMTP and IMAP servers and their security settings 

manually in <Manual config>: 

 

Server names are of the form: productID.securium.ch (where “productID” is unique identificator of 

your company’s SWISS SECURIUM® instance and standard part “.securium.ch”). Choose also 

SSL/TLS protocol from the drop-down menu in the SSL column. 
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2.2 Address Book synchronization 

 

You can synchronize your Address Books collected in both webmail and Thunderbird: 

1. Download webmail connector from the website: https://sogo.nu/download.html#/frontends; 

2. Choose Tools → Add-ons in Thunderbird menu; 

3. Install downloaded Add-on from file: 

 

4. Login to your account of MailSecurium™ and go to the Address Books tab; 

5. Choose the Address Book to synchronize and click the menu icon  next to it, then choose 

<Links to this Address Book> : 

      

6. Copy CardDAV URL: 

 

https://sogo.nu/download.html%23/frontends
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7. Go to Address Book in your Thunderbird and click File → New → Remote Address Book and 

enter a name for new Address Book, insert copied CardDAV link and adjust settings (if you 

need). 

Now your Address Books are synched. 

If you previously used the Thunderbird for another email service and collected many contacts in its 

address books, then you can transfer these addresses to web interface of MailSecurium™ using 

contact export/import: 

1. Go to Thunderbird Address Book and choose Tools → Export… 

 

2. Export your Address Book in LDIF format (supported by MailSecurium™): 

 

3. Login to your account of MailSecurium™ and go to the Address Books tab; 

4. Choose the Address Book to upload your file and click the menu icon  next to it, then 

choose <Import> and choose the file from your computer. 

 

2.3 Calendar synchronization  
 

MailSecurium™ has very convenient and functional calendars that simplify collaboration and 

planning. And if you prefer to use the mail client, you can configure the synchronization of personal 

and corporate Web calendars with it: 

1. Click Tools → Add-ons in your Thunderbird menu; 

2. Search for "Lightning" add-on and install it (requires restart of Thunderbird); 

3. Login to your account of MailSecurium™ and go to the Calendar tab; 
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4. Choose the Calendar to synchronize and click the menu icon  next to it, then choose <Links 

to this Calendar> : 

 

5. Copy CalDAV link to this Calendar: 

 

6. Create new calendar in Thunderbird: File → New → Calendar → On the Network; 

7. Choose CalDAV format, enter your Username (part of your SWISS SECURIUM® Platform 

email before @) and copied link: 

 

8. Enter a name for new Calendar. 

Now you can see your calendars from MailSecurium™ in Thunderbird. 
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3 ENCRYPTION OF YOUR EMAIL IN THUNDERBIRD 
 

Enigmail is an extension for Mozilla Thundebird and other Mozilla-based mail clients. It allows you to 

encrypt and digitally sign emails using OpenPGP standard based on p≡p. It is free and released under 

an open source license. 

Gnu Privacy Guard (GPG) is free and open source software capable of encrypting, decrypting and 

digitally signing messages and files. It also generates and manages the public and private keys needed 

to do so.   

Public email services can’t provide full privacy, while Thunderbird Enigmail may make your mail 

correspondence fully private using methods of modern asymmetric cryptography. 

 

3.1 Installing Enigmail 
 

The extension can be installed (and removed) through Thunderbird’s <Add-ons-Manager>. Start it 

like shown: 

 

Note: Thunderbird menu may be quite difficult to reach on Windows using the standard layout. Click 

on the shown icon to open the menu and select <Add-ons>: 
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Enigmail can be selected <Featured Extensions> or searched and installed: 

 

You will get a confirmation dialog, to not download software from unknown sources. However, the 

Mozilla site can be trusted and you can confirm. After installing the extension, you must restart 

Thunderbird to activate it. 

Linux users: If you install all your software packages from a repository, you may find that it contains 

an older (but security-patched) Thunderbird version. Please use the (matching) Enigmail package from 

that repository. 
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3.2 Quick Start 
 

This section assumes that Thunderbird and Enigmail are installed by now. Otherwise, please head 

back to the section 3.1. 

In particular, the Quick Start Guide assumes that: 

 Thunderbird is installed and 

o all email accounts and identities are set up 

o you can receive and send (unencrypted/unsigned) e-mail 

 Enigmail is installed  

o but not configured yet (default values are set) 

o you didn’t restart Thunderbird since installing Enigmail 

 GNU Privacy Guard 

o may or may not be installed yet and 

o keys may already exist in your keyring or not 

Even if you already modified Enigmail settings or have existing keys, you should be able to follow this 

guide. Adapt for your situation, like rather choosing an existing key instead of creating a new key. 

After restarting of Thunderbird, the Setup Wizard window appears. This wizard will guide you 

through all steps to configure Enigmail. 

Using the Setup Wizard is not necessary. Experienced users may as well configure Enigmail by hand. 

The Setup Wizard starts automatically when restarting Thunderbird after installing Enigmail. The 

following dialogs will guide you through a basic setup. You may cancel this wizard any time and 

(re)start it from the menu. 

The first screen asks you whether you want to start the setup (choose an option and click the 

<Continue> button): 

 

The next screen will show a selection for your experience level: 
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In most cases it’s preferable to select “I prefer a standard configuration (recommended for 

beginners)”. 

Advanced users, e.g. previous users of OpenPGP encryption may want to select the second option. 

Expert users can use the third option. This is intended for users having good experience of Enigmail. 

After you have made your choice, click on <Continue>. 

For every choice, the next step will download and install the Gnu Privacy Guard (GnuPG), if the 

Enigmail Setup Wizard cannot find it on your computer. 

 

If you are certain that GnuPG is available on your computer, please point Enigmail to the installed 

GnuPG program by clicking on <Browse…> to select the GnuPG program folder. 

Otherwise, please click on <Install…>. Then Enigmail setup wizard will download the required 

package (different for Windows and Mac OS X) and start the Installer of that package. 

On Linux there is almost always a usable version of GnuPG, so this step is not needed there. 

 

This screen is shown during download and run of the GnuPG installer. 

Note: The package is downloaded through a SSL secured connection. Furthermore, its checksum will 

be verified by Enigmail so the package is trustworthy. 
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First selection: Choice of language. 

 
Second screen: Welcome message, click <Next>. 
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License agreement. Click <Next>. 

 
Selection of components (there's only one and compulsory component). Click <Next>. 
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Select the folder where the program shall be installed (leave default if you're not sure). Click <Next>. 

 
Select where you want links to the program being placed. Click <Next>. 
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If you checked <Start Menu> in the previous screen, select the Start Menu folder where the shortcut 

shall be placed in. 

 
Now the installer performs its work showing a progress bar. Click <Next> when finished. 
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Now the installer has finished. Check the <Show README> file if you want to read it. Click <Finish>. 

Congratulations! Now you have successfully installed the required GnuPG package for your platform! 

 

3.3 Setting up your privacy 
 

The next screen shows the wizard, if you selected <Standard configuration>: 

 

Select the account/User ID you want to use with Enigmail. Don't worry, you can add other 

accounts/User IDs later if you wish to do so. Click <Continue>. 

The Wizard will help you to get your key pair. There are several ways to obtain it: 

1. Generating a new key pair 

2. Using an already existing key pair 



28 
 

The wizard will guide you through the possibilities. If there is an already existing key pair on your 

computer, Enigmail will detect it and offer to use it. 

More likely, as this is the first time you use Enigmail, you will need to generate a new key pair. The 

wizard will do this automatically for you: 

 

 
 

You will be asked to choose a passphrase to protect your key pair: you will need that passphrase for 

signing or decryption of a message later. Please repeat the passphrase (just to be sure there's no 

typo). 

 Important: Please make sure, that you remembered that passphrase! If you forget it, you will not 

be able to use your key pair any longer! Everything encrypted for this key pair will be lost. 

Once the key has been generated, the wizard will display a confirmation together with the button 

<Create Revocation Certificate>.  Doing this is absolutely necessary! If you lose your key or 

forget your passphrase, you can use this revocation certificate to revoke your key. Click on this 

button, and you will be prompted for a location on where to save the revocation certificate. Please 

save it in a safe location outside of your computer! This can be done afterwards. 

Close the dialog clicking on <Continue>. 

The Setup Wizard has done its job, and Enigmail is ready to use! 
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3.4 Start using Thunderbird with Enigmail 
 

When you start editing an email, you will now notice a new Enigmail toolbar below the normal 

toolbar of the Compose window. This toolbar allows you to sign and/or encrypt the message using a 

single click on the shown icons. On the right end of this extra toolbar, a pen and/or a key icon are 

displayed, to show if signing and/or encryption is enabled. 

If you miss some of the icons, you can configure this toolbar like the normal toolbar above: Right click 

(or CTRL-click on Mac OS X) and select <Customize> from the appearing pop-up menu. You can now 

drag icons into the toolbar or remove them as you like. 

 

You can immediately send signed mail to anyone. However, in order to allow someone to verify your 

signature or to send you an encrypted message, you must provide them with your public key. You 

can send your public key as an attachment either by clicking the “Attach My Public Key” button in the 

Enigmail toolbar or by choosing Enigmail → Attach Public key... in the Compose window, and then by 

selecting your key in the Key Selection window that will appear. 

All your stored keys (your own key pair, and other people's public keys you have acquired) can be 

seen in the Key Management, via the menu command Enigmail → Key Management. 

To send encrypted mail, you need to have the public key of the recipient. You can acquire it in one of 

the following ways: 

 ask them to email you their public key as an attachment; then right-click on the attachment 

and choose Import OpenPGP Key; 

 retrieve their public key from a keyserver via Keyserver → Search for keys from Key 

Management; 

 download their public key from their web site as an ASC file, then import it via File → Import 

Keys From File from Key Management; 

When you receive an email that has been OpenPGP-secured (signed and/or encrypted), it will appear 

as such: 

 

The message on the picture above has been decrypted, as shown in the Enigmail status bar. 
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3.5 Key management 
 

Once you have Enigmail and GnuPG on your system, you need to populate it with keys: it's pretty 

useless without them. You need to have your own key pair in order to sign messages and allow 

anybody to send encrypted messages to you. Furthermore, you will need the public key of a person 

in order to send that person an encrypted message, or to verify the signature in a message sent by 

that person. 

Select Enigmail → Key Management to open the Key Management window. 

 

The Key Management window shows all keys (yours and other people's) you have stored on your 

computer; this is called your keyring. The set of all public keys that you have collected is often called 

your public keyring. 

Key pairs (i.e. a bundle of public key and its companion secret key) are shown in bold. Revoked or 

expired keys are shown in italic. 

If you have run the Setup Wizard and generated a new key pair, or imported an existing one, it will be 

shown here. (If it doesn't, tick the option Display All Keys by Default.) Otherwise, the window will be 

empty. 

By clicking the expand arrow (1) at the left of each key, you can see the key's additional user IDs and 

PhotoID, if present. The columns (Key ID, Type, Key Validity, Owner Trust, Expiry, and Fingerprint) 

show a number of other key properties: you can choose which columns you want to see by selecting 

them in the rightmost icon (2) in the column header bar. 

The menu bar of the Key Management window allows you to operate on the keys of your keyring. To 

do that, select a key, and then choose a menu item. You also have most of these menu items in a pop 

-up menu that shows up when you right-click on a key. Some menu items will be disabled (greyed 

out) if the operation is not possible on the key you selected.  

Select your key pair and choose View → Key Properties. Most of these properties can also be viewed 

directly from the Key Management window. 
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1 The Primary User ID is the name and email address associated with the key i.e. the key 

owner's.  

2 The Type of the key shows “key pair” (“pub/sec” in Key Management window) to mean that 

this is a key pair. For other people's public keys that you have imported, this field will show 

“public” (“pub” in Key Management window). 

3 The Fingerprint is a unique 40-digit hexadecimal number automatically generated by applying 

a hash algorithm to the key. The fingerprint unambiguously identifies the key worldwide. This 

means that no key will have the same fingerprint of another key ever created in the whole 

world. 

4 The Additional User ID field show the other user IDs (name and email address) associated 

with the key, if any. Process of creating the additional user ID will be explained below. 

5 Key validity shows you whether the key has expired or has been revoked. For the key pair 

that you just created, validity should display “ultimate”. This field is directly related to the 

Web of Trust model, explained below, and is related to public keys purporting to other 

people. 

6 Owner trust (You rely on certification) indicates the trust in the key's owner on verifying 

other keys carefully before signing them. For your own key pair, it should display “ultimate”. 

For other keys it will display what you have entered. The “Owner trust” property is not 

exportable. 

7 The last 16 digits of the fingerprint make the short Key ID which, being much shorter, is used 

to locally identify the key for all practical purposes.  

8 The <Structure> tab shows all key components i.e. primary key and subkey(s) along with their 

properties: the key ID, the algorithm used for the key, the key size in bits, the creation date, 
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and the expiration date (if any) and the key capabilities (possible values: Sign, Certify, Encrypt 

and Authenticate). 

9 Key ID and fingerprint are often prepended by the characters 0x, which is the prefix 

indicating a hexadecimal number. 

10 A drop-down menu <Select action> at the lower left of the Key Properties window allows 

you to perform different operations on the key. The same operations are available from the 

menu bar within the Key Management window as well. 

Now click the <Close> button to close the Key Properties window and go back to Key Management. 

Specifying additional user IDs 

You might desire to use more than one email address to send secure email from. In this case, you 

don’t need to generate one key pair for each address: you may simply associate multiple email 

addresses to your key pair. This will save you from the burden of managing multiple key pairs. 

Select your key pair and choose Edit → Manage User IDs from Key Management, or choose Manage 

User IDs from the Key Properties of your key. A window will pop up to show you a list of all user IDs 

(primary user ID and all additional user IDs) that are currently associated with the key. If this is the 

first time you perform this operation, your key will have only a primary user ID. 

 

The Add and Delete buttons add and delete other user IDs. A user ID is composed of a name and 

email address; it is also possible to put an optional comment. 

The Set primary button sets the selected user ID as primary, and as a consequence the previous 

primary user ID is relegated to the role of additional user ID. 

The Revoke button revokes the selected user ID, which is then greyed out and deactivated. The 

difference with deletion is that a revoked user ID is still associated to the key pair but no longer 

usable. 

All user IDs are included in the public key when it is sent or exported. There is no mechanism in 

OpenPGP for selecting which user IDs are included and which not. This also applies to the PhotoID, 

which is a special type of user ID. 

Adding a PhotoID 

Public keys may have an embedded PhotoID i.e. the owner's photograph. To view the PhotoID, select 

the key and choose View → PhotoID from Key Management, or click the View PhotoID button from 

the Key Properties. If the menu item or button are greyed out, the key carries no PhotoID. 
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To add a photo to your key, click on your key and select <Add Photo> from the popup-menu. Then 

enter the path of your image file. Suggested image sizes are 240x288 pixels (GnuPG) or 120x144 

pixels (PGP). 

The image will be included in your public key as an additional user ID. For this reason, GnuPG and 

PGP recommend to use JPEG files of maximum 7 Kb, otherwise your public key may become very big 

in size. 

Changing the passphrase 

To change the passphrase that protects your private key, click on your key and choose Edit → 

Change Passphrase from Key Management, or click the Change Passphrase button from Key 

Properties. GPG-Agent will ask you twice for the new passphrase – just to be sure that there are no 

typos. 

Making a backup of your key pair 

Once you've generated your key pair, verified its properties, it's a very good idea to make a backup 

copy of it. 

Select your key pair from Key Management and click on File → Export Keys to File. You will be asked 

whether you want to include your secret key in the saved OpenPGP key file: 
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If you now click on <Export Secret Keys>, the exported file will contain your whole key pair (secret 

key and public key). If you click on <Export Public Keys Only> instead, the exported file will contain 

your public key only. 

 NOTE: Be very careful on how you export your key pair: when backing it up, you must include 

the secret key, or the backup will be useless. When exporting in order to distribute your public key, 

make sure you do not include the secret key, or you'll compromise your key pair. 

Distributing your public key 

Now that you have a key pair, you must distribute your public key around. This is necessary so 

people can use it to send you encrypted messages and verify the signature on messages you send. 

You can do this manually and/or by the means of a public keyserver. 

 Share your public key manually 

On the Key Management window, select your key pair and click on File → Export Keys to File. Again, 

you will be asked whether you want to include your secret key in the saved OpenPGP key file: make 

sure you click on <Export Public Keys Only> this time. Save the ASC file, which will have a name like 

Firstname Lastname your@domain.com (0x89ABCDEF) pub.asc. 

This is a copy of your public key; notice the “pub” word at the end of the filename. You can now put 

the file on your website for people to download it, or carry it around in a USB drive to distribute it to 

people, or send it via email as an attachment. 

Concerning this last option, there is a simple Enigmail shortcut for it: when writing your mail in the 

Message Composition window, simply click on <Attach My Public Key> or choose from the menu bar 

Enigmail → Attach My Public Key, and Enigmail will attach it upon sending. 

Publish your public key on a keyserver 

The easiest way to let the world know your public key is to publish it on the public keyserver 

network – a global database of keys. 

In order to publish your key, click on your key and select Keyserver → Upload public keys. You will 

be given a choice of keyservers; pool.sks-keyservers.net is the one Enigmail uses by default. Major 

keyservers periodically synchronize themselves. 

 

Click on <Ok> and wait for your key to be uploaded. Your key is now published on the Internet for 

anyone to find. 
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Importing public keys 

You need someone's public key to accomplish two things: encrypt an email to this person and/or 

verify the signature of an email coming from this person. 

You might obtain the public key as an ASC file from the person themselves, either as an email 

attachment or by hand. In this case save the file on your computer, then from Key Management 

select File → Import keys from file. Choose the ASC file you just saved. Enigmail will add this public 

key to your keyring. 

Another way to find someone's public key is to download it from a keyserver. 

Select Keyserver → Search for keys and insert as the search term a part of the name or email address 

of this person. You may also search for key IDs. The keyserver will return a list of public keys that 

match. Tick the checkboxes on the left of any key you would like to import and Enigmail 

automatically will do it for you. 

Later, you can also refresh your public keyring in part or as a whole by the menu commands 

Keyserver → Refresh Selected Public Keys and Keyserver → Refresh All Public Keys. 

You can search and add public keys to your keyring at any time. Enigmail will also offer to do so 

automatically when you receive a signed message from someone and you do not have their public 

key. 

If you followed all instructions up to here, by now your keyring should contain your own key pair and 

a number of public keys purporting to other people. 

Validity of public keys 

Importing a public key from a keyserver is quick and easy, but it doesn’t guarantee that the key really 

purports to the person specified as the user ID. After all, anybody could have generated and 

uploaded that key. Fake keys on keyservers are the fact. 

Furthermore, if you received someone's public key via email, you should reflect on the fact that there 

is an inherent security problem in using the same channel (e-mail) both for key distribution and for 

the exchange of messages secured by that key. Theoretically, an attacker that is able to compromise 

the channel can replace the public key in transit with a rogue public key of a key pair he created 

himself (man-in-the-middle attack). The attacker can now intercept the message that was encrypted 

with the rogue public key, and decrypt it since he owns the companion private key. 

Verification of public keys 

A solution to this problem is to check the public key's fingerprint with the key owner through a 

different channel. You may phone the key owner and have him read the key fingerprint to you. If the 

fingerprint does not match, you both know that the key was replaced in transit or you were 

otherwise given a fake key. 

However, the best way to verify other keys is to meet the person face to face, check their identity 

(by the passport, e.g.), receive the fingerprint of their key and let them state which mail addresses are 

associated with this key.  

This procedure is safe but can be very difficult to do. Imagine, your mail correspondent lives very far 

away and you cannot meet in person. This problem was therefore addressed in OpenPGP by 

developing a trust delegation model called Web of Trust. But before this is explained, there is another 

important thing: 
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Signing other keys 

Finally, if you have verified a public key, you should tell it to the OpenPGP system. This is done by 

signing your email partner’s key. Signing is needed to make this key valid and usable for you. 

In key management, select the particular key and then either using the menu item Edit → Sign Key or 

right click (Mac OS ctrl+click) and select <Sign Key> from the appearing popup menu. Then the 

signing dialog will open: 

 

The key to be signed is shown with its User ID (name and mail address), followed by the short Key ID. 

The next line shows the fingerprint of the key. You should check it again!  

The third line shows the secret key you are signing with. In most cases, there will only be one, 

otherwise you can select by a drop down menu. 

You are asked how carefully you have verified that the key you are about to sign actually belongs to 

the person named in the first line. 

 I will not answer (this is the default) 

o Select this, if you don't want to tell anybody how you did verify this key 

 I have not checked at all 

o You should only do this, if you want to keep your signature local 

 I have done casual checking 

o This option may be selected if you have e.g. received the fingerprint by phone and 

not met the person yourself 

 I have done very careful checking 

o Only select this option if you have carefully checked the person’s passport or a similar 

ID document. 

Then there's a checkbox at the bottom: Local signature (cannot be exported). Check this if you do not 

want to become your signature public. This is extremely helpful when you have not met the person in 

real and only want to get that key into “valid” state.  

If you later – after meeting face to face and thorough verification – decide to issue a public 

(exportable) signature, you can then repeat this step without checking the <Local signature> box. The 

exportable signature then replaces the local signature. 
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Click on <Ok> to perform this operation. Your signature will be attached to that public key; if the key 

was already signed by other people, your signature will be added to the list. When a key is exported, 

the list of signatures is exported with it. 

Once you have signed a public key, you should return it (for instance in a signed email message) to 

the owner so he can redistribute it and upload it again on a keyserver. 

Note that you can upload your public keyring to a keyserver by the means of the menu command 

Keyserver → Upload Public Keys, but doing this without consent of the key owner is not considered 

good netiquette. 

The Web of Trust 

Now that we have discussed how you can establish trust by verifying keys from people you know, 

let's see how you can extend this zone. In the Web of Trust model, responsibility for key validation is 

delegated to other people you trust. 

For instance, Alice would use her key 0xAAAAAAAA to sign Bob's public key 0xBBBBBBBB to certify 

that the particular public key is belonging to the individual called Bob. Bob has signed Carol's public 

key 0xCCCCCCCC. From this, Alice can infer that Carol's public key is valid (i.e. public key 

0xCCCCCCCC purports to the individual called Carol) because there is a path of valid signatures from 

her public key to Carol's. 

The View → Signatures menu item in Key Management, or the View Signatures button in Key 

Properties, allow you to view the signatures attached on a key i.e. by whom this key has been signed. 

Participation to the Web of Trust is completely voluntary: you do not need to publicly sign other 

people's keys or to publish your key to successfully use GnuPG or Enigmail. 

Owner Trust 

A quick note in advance: “Owner trust” is one of the most misunderstood things in the Web of Trust 

context. In fact, “Owner Trust” DOES NOT tell anything about the owner’s key or if it should be 

treated as valid or not. 

The parameter “Owner trust” tells OpenPGP in how it should respect other keys signed by this 

owner’s key. 

You alone decide how much you trust the practice of particular key signer. In the previous example, 

Alice could decide that she does not trust the keys signed by Bobs key, because she knows that Bob 

is happily signing any public key he gets his hands on without caring to verify the owner's identity. In 

this case she sets the owner trust level of key 0xBBBBBBBB (the key Bob uses to sign other people's 

public keys) to “None”. Carol's public key 0xCCCCCCCC will therefore not be calculated as “valid” in 

Alice’s installation, if there is no other trust path. 

Here, “Owner Trust” refers solely as Bob's capacity to properly validate public keys. It doesn’t infer 

anything else concerning Bob as a person. It doesn’t concern, neither, the content of Bob's messages 

being truthful or not. 

You only should set “Owner Trust” for a person, if you have watched her/him in real life how careful 

she/he is checking the identity, the fingerprint and the mail address(es) of other key holders. The best 

reference to judge is how she/he did check YOUR identity. 
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There are five levels of Owner Trust: 

 Unknown. Nothing can be said about the owner's judgement in key signing. This is the trust 

level initially associated to other people's public keys in your keyring. 

 None. The owner is known to improperly sign keys. 

 Marginal. The owner is known to properly sign keys. 

 Full. The owner is known to put great care in key signing. 

 Ultimate. The owner is known to put great care in key signing, and is allowed to make trust 

decisions for you. 

You can set the level of trust of a particular key by selecting that key and choosing the option <Set 

Owner Trust> from Key Management, or from Key Properties itself. 

You alone decide which level of trust to assign to a key, and the trust is assigned only locally. This is 

considered private information: it is not included with the key when it is exported, and is stored in a 

separate place from your keyring. 

The trust level of your own key pair should be set to the maximum (I trust ultimately). 

Criteria for Key validity 

Keys signed by your key are automatically regarded as valid. This is the gold standard. 

If you didn't sign a particular key, the Web of Trust decides whether a key is regarded valid or not. 

Within this model, the Owner Trust you set on the keys which signed a particular key is used to 

calculate their validity. 

A side note: The owner trust level is your individual setting. As a consequence, the calculated validity 

of a key is unique for your local installation of OpenPGP. That is, a key you consider valid might be 

considered invalid by someone else. 

A key is considered valid if it has been signed by at least one key set to full owner trust, or by at least 

3 keys with marginal owner trust setting. In addition to that, the path leading from that key back to 

your own key must be 5 steps or shorter. 

This is explanation is quite abstract, so here is an example taken from the real world: 

I have signed the key of Patrick Brunschwig, our project head. I didn't meet Nic Josuttis, another 

member of our team in person. I've seen that Patrick carefully verifies other keys before signing, so I 

set the owner trust on his key to “full”. 

Now, as he also signed Nico's key, Nico's key is regarded as “valid” in my keyring. 

Ultimate owner trust bypasses any restrictions on how many fully trusted signatures are needed to 

make a key valid: any key signed by an ultimately trusted key is always valid. You can set ultimate 

trust to a particular key you want to allow to make trust decisions for you. This should only be done 

with extreme caution. 

You can see the calculated validity and your assigned owner trust value in the Key Management or 

Key Properties window, in the fields <Key validity> and <Owner trust>. You may have to expand all 

columns to get a similar view: 
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Importing an existing key pair 

Perhaps you have already used GnuPG, Enigmail, or any other OpenPGP software in the past, and 

you generated a key pair in that occasion. If you didn't do so already using the Enigmail Setup Wizard 

you might want to use your existing key pair in this installation of Enigmail. Make sure you remember 

the passphrase of your old key pair, otherwise you will be unable to use it. 

To import your key pair, choose File → Import Keys From File and select the file containing your key 

pair. Your key pair will be imported for you to use it. 

Generating your own key pair 

You need to own a key pair to join the community that communicates securely using GnuPG. You can 

create one at any moment by selecting Generate → New Key Pair. A window will open: 
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To successfully generate a key pair, you must proceed through the following steps. 

Tell Enigmail which account to use 

The Account/User ID drop-down menu shows all your email accounts and identities you have 

configured in Thunderbird: you must select one to associate to this key pair. Select whichever 

account will be receiving encrypted mail, and make sure the option Use generated key for the selected 

identity is ticked. Later, you can change the email address associated to the key pair, or use the same 

key pair for multiple email addresses. 

In the optional Comment field, you can write something about this key pair. It’ll help you distinguish 

keys for different purposes. The comment will appear next to the User ID. Note that the comment 

will also appear in the exported public key that you distribute to other people. 

Choose the expiry of the key 

It may happen that someday you lose your private key or your passphrase, and therefore you’ll be 

unable to use your key pair. It may also happen that your private key gets compromised e.g. an 

intruder manages to have access to your computer and steal your key pair, or you could send 

someone your private key by mistake. 

Furthermore, there might be some breakthrough in cryptanalysis or simply the discovery of a 

weakness in a cryptographic algorithm, although this possibility is more remote. In this case, the 

cipher and key size you chose for your key pair many years ago could be unfit for offering valuable 

security in today's standards. 

In all these cases, it’s a good idea to have a key pair that is valid only for a limited period of time. 

The <Key Expiry> tab allows you to limit the lifespan of your key pair. After the allotted time, the 

public key will automatically be marked as invalid (expired), and people will be prevented to use it. 

The messages previously encrypted and signed with that key pair will still be decryptable and 

verifiable, though. Once your key pair has expired you can either extend the expiry time or you can 

generate another one, and distribute around your new public key. 

A good time lapse for key expiration is between 3 and 5 years. You may also choose to have a key 

that never expires, although it’s not recommended. 

Choose the key type and size 

By clicking the <Advanced> tab you can choose some properties used for the generation of your key 

pair: the Key size (1024, 2048 or 4096 bits) and the Key type, which defines which cipher will be 

used (RSA or DSA & ElGamal). Basically, the larger the key size, the stronger the key, the greater the 

processing power requested for encryption/decryption. If you are going to send a lot of messages 

that will be decrypted on old computers or on mobile devices, you should probably choose a 2048-bit 

key. Otherwise, you don't really need to ponder your choice: the default option (4096-bit RSA key) 

offers excellent security coupled with a good usability, and will work fine. 

Start key generation 

Once you made all these choices, simply click on the button <Generate key>. 
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Choose a passphrase 

Upon clicking on <Generate Key> you will be asked by the GPG-agent two times to set the secret 

passphrase for your new key pair.  

Your private key is all you need to send signed messages and decrypt messages that you receive on 

your selected email account. If the private key fall in other hands, this would allow someone else to 

sign messages on your behalf and decrypt messages that were supposed for your eyes only. 

Luckily, GnuPG uses an additional layer of protection: the private key is protected with a secret 

passphrase. Choose something for your passphrase that is easy to remember but very hard for 

someone to guess. 

 If you forget your passphrase, you will be unable to use your private key! There is no way to 

recover the passphrase. Your only hope is to try to remember what the passphrase was. This is a 

security feature of GnuPG and cannot be circumvented. 

After entering your passphrase twice, the key will be generated. 

Key generation process 

On a modern computer, a standard 4096-bit RSA key pair takes no more than a dozen seconds to 

generate. 

Congratulations! You just created your first key pair. 

Generate the revocation certificate 

It may happen that your private key gets lost or compromised. In this case it is of crucial importance 

to have a revocation certificate for that specific key pair. 

Once it finishes generating your key, Enigmail will offer you to also generate such a certificate. If you 

accept (which is recommended), click on <Generate certificate>. You will be asked where to save the 

revocation certificate file. 

Keep the revocation certificate in a safe place and not on the same computer you installed Enigmail, 

so if you even lose your key pair (e.g. due to a hard drive crash) you don't lose the revocation 

certificate with it. An external hard drive, where you also put a backup copy of your key pair, will be 

fine. 

The revocation certificate can be used to invalidate your key pair at any time. You don’t need to type 

your passphrase or physically have in your keyring the key pair you are revoking, so this will work 

great even if you forgot your passphrase or accidentally deleted your key pair.  However, keep in 

mind that anyone having access to the revocation certificate can revoke your key pair! You may also 

generate the revocation certificate at any later time by selecting your key pair and choosing Generate 

→ Revocation certificate. 

Revoking your key pair 

In the unfortunate event that you lose your key pair or feel it has been compromised, you should 

revoke it. This can happen in many ways: 

 Somebody not authorized got access to your computer 

 Somebody not authorized got access to your key backup 

 Your backup media is lost 
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 The used key algorithm has been found to be cryptographically broken 

You can use the revocation certificate that you generated in advance to invalidate the key pair. Select 

File → Import keys from file from the <Key Management> window and choose the ASC file 

containing your revocation certificate. 

If you do not have your keys any longer but the revocation certificate, then you must first get your 

public key, e.g. from a keyserver or a mail correspondent. Then, as a second step you can import your 

revocation certificate via File → Import keys from file from the <Key Management> window and 

choose the ASC file containing your revocation certificate. 

If you did not generate the revocation certificate in advance, you can revoke the key on the fly, 

provided that you still have your key pair and you remember your passphrase. To do so, select the 

key pair you want to revoke and click on Edit → Revoke key. This will create a revocation certificate 

and import it in one shot. 

Send the revoked key to your contacts to warn them not to use it any more. If you published your 

public key on a keyserver, remember to upload again the revoked key to it. 

 


